Using EstimatorXpress with Office 2016


Microsoft have just released the new Office 2016 suite.


You will need to be running EstimatorXpress 2015 v9.00.8 or newer to be compatible with Office 2016.


The EstimatorXpress update link is here:


EstimatorXpress Update for V7 , V8 and 2015



Did you find it helpful? Yes No

Send feedback
Sorry we couldn't be helpful. Help us improve this article with your feedback.

Modified on: Mon, 15 Feb, 2016 at 11:12 AM