Your current version is PlansXpress version 4 or older


If you are running PlansXpress v.1, v.2, v.3 or v.4 and want to get the latest version of PlansXpress you will need to upgrade online or call our Accounts Management Team on 0117 916 7892

PlansXpress v1, v2 and v3 are no longer supported.

  • Support for PlansXpress v1 ended 4th December 2010
  • Support for PlansXpress v2 ended 20th October 2013
  • Support for PlansXpress v3 ended 8th August 2016
Upgrade Now

Did you find it helpful? Yes No

Send feedback
Sorry we couldn't be helpful. Help us improve this article with your feedback.

Modified on: Wed, 19 Sep, 2018 at 11:09 AM